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1 - LET’S GO BACK TO OUR NEW DOC
catalog test1



GUIDES THAT CAN HELP A LOT
Here we can see a modular grid  that consists of rectangular 
areas of same size, so that one might use one or more of these 
spaces to place text and graphics. 
The same number of columns and rows is used throughout the 
document. Note that images or illustrations may span two or 
more columns.  

By selecting File > Document Settings > Guides (for the 
current document) or File > Preferences > Preferences (for 
all future documents), you have the ability to change some 
settings for guides, such as the placement above or below 
content, activity of the snapping, and the color of the guides. In 
addition, you might choose to show a grid. The grid has two 
kinds of lines, major (thicker) and minor (thinner), with the 
spacing of each adjustable. 

You can also show the baseline to align your text with. Choose 
the linespacing you desire then remember to style your text 
accordingly Edit>Style> Body text > Align to the baseline



CREATE YOUR OWN GUIDES
The simplest method to add guides is to click and drag from the ruler areas.  

Click-dragging from the ruler will create vertical guides, and from the top ruler, 
horizontal guides. If you don't see anything, make sure you have View > Show 
Guides checked in the menu. Next, make sure you have checked Page > Snap to 
Guides to align your frames.  

To move your guides, hover the mouse over the guide until you see the cursor 
change to a double arrow shape, at which time you can click-drag to adjust its 
position. To delete a guide, click-drag off the page, then release the mouse button.  

MANAGING GUIDES  

When you want to shape your layout according to the dimensions of your page 
size or the space inside the margins, you may use Page > Manage Guides so you can 
place with high precision single o double guides. Here you may also lock guides 
to prevent accidental changes.
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3 - CREATION OF MASTER PAGES
Master Pages contain 
objects which are seen 
again and again in your 
document  

Typical objects on a 
Master Page might be 
titles with associated 
graphics, headings and a 
page numbers. 

Edit > Master Pages 
from the main menu. 
Note that whenever the 
Edit Master Pages dialog 
is open, you see and you 
are editing Master Pages, 
not the document page.

By clicking Windows > Arrange Pages you bring up a dialog, 
which lists your Master Pages and Document pages, this can 
be used for navigation and also for assigning or reassigning 
Master Pages to various document pages. To apply a layout to 
a page just drag the template onto the page. Double-clicking 
on a Master Page will bring up the Edit > Master Pages dialog.



HEADINGS, FOOTER AND PAGES

Now let’s create a Master Pages with appropriate placement of 
headers and page numbers (you might also begin to create 
objects which will be repetitively used and save them to your 
scrapbook). 

When you manage a Master page you see and work on the canvas 
of a Master Pages, not on the document page. Create a heading 
(author name and title) and  a footer (name of the book series 
and number of page). In this case create a text frame click inside 
than go to Insert> Page Number and format if necessary. You 
will see a hashtag # that automatically will be filled with the right 
page number. To return to the document close the Master Page 
palette.
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4 - THE TEXT

➤ From menu: Insert > 
Insert Text Frame (From 
the icon click-drag-
release)  

➤ Double-click inside the 
frame to type: you are now 
in Edit Contents mode 

➤ Remember to open the 
Properties palette 
(Window > Properties),

The Properties panel is the heart of Scribus, 
everything that is placed on the page is controlled 
from this panel  
Here you can try various fonts and font size of the 
characters and you can adjust the linespacing. (In 
general, a minimum spacing of 20% greater than 
font size is advisable). 
But this is not the way we need to work when we 
realize a layout.  
We need to operate with  the STYLES… let’s see 



TEXT EDITOR AND GET TEXT
Scribus is not the best tool for 
composing text. You usually need to 
import texts written with different text 
editor.  

Create a text frame Select the frame, 
then from the menu,  
File > Import > Get Text to import the 
text you have in your file txt 

Scribus has the capability of working 
stylized text from some word processors 
BUT this does complicate the process of 
incorporating the text into Scribus.  

Better use a plain text editor that 
allows the graphic designer complete 
freedom of decision-making regarding 
text styles.  

Story Editor is the editing window used to 
manually enter text into a text frame. It is 
currently mainly meant to display the text 
content. You can copy your plain text here and 
formatting it than transfer it in the right frame in 
the layout
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text frame, From 
the pop-up menu, 
choose 'Get 
Text...'. Select 
the .txt file, and 
press 'Open'. You 
will see the text 
flow into the 
frame. At the 
bottom-right of 
the text frame 
you'll see a 'X' 
mark in a box, 
which means 
there's more text 
than can fit in this 
text frame.  
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5 - THE STYLES
A good working method would be to choose 2 or 3 fonts 
(one for titles, one for the body text), and 2 or 3 
reference colors that will be in your color palette.  

Character styles should be decided for the body text, 
headings, captions, boxes, numerals, and other element)  

Paragraph styles are about indentation, line spacing, 
space above or below a paragraph, justification, tabs, 
drop caps). You can easily choose them while you 
work at your layout and change them whenever you 
like. 

1. Bring up the Style Manager with Edit>Styles. 

2. Click the New button, then from the drop-down list 
choose the type of style you wish to create. 

Once you create styles, with one click you can apply 
them to large bodies of text, then if you later modify 
your style, it will automatically be updated wherever it 
has been used

You can set 
even a single 
character 
(Dropcap)
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6 - SAME GRID DIFFERENT LAYOUT
Now we have to create the layouts. Look at your 
flat plan 
you will have 
➤ a cover 
➤ a title page 
➤ a colophon 
➤ an index (better if  interactive) 
➤ the introduction to the series (if your catalog 

is part of a series of books of the same specie)  
➤ the general introduction 
➤ the biography of the author 
➤ the portfolio  
and so on…. 
Each one of them will have its peculiarities and 
its similarities  
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7 - THE IMAGES
We already know how to insert the text. 
Next step will be to place an image  

Activate the image frame tool from the 
menu (Insert > Insert Image Frame) or 
click the Insert Image Frame icon from 
the toolbar, and then with a click-drag 
motion create an image frame. 

Make sure you have selected the image 
frame, then load the photo which you 
should find in your directory Images inside 
your working directory for this project by 
using File > Import > Get Image. 

Most likely, your image do not appear – 
don't panic, what you are seen is a small 
part of the image. Bring up the Properties 
palette (Windows > Properties), select the 
Image tab, and select the options Scale To 
Frame Size and Proportional.

By default, Scribus will import images 
according to their resolution as noted in the 
file. Since there isn't yet any information about 
the resolution you would like to use, Scribus 
simply loads the image at its maximum size.
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By default, Scribus will import images 
according to their resolution as noted in the 
file. Since there isn't yet any information about 
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➤ A quicker way to carry out this operation is to 
right-click on the image frame and select Adjust 
Image to Frame from the context menu. 

➤ Next, adjust the image frame by right-clicking, 
then choosing Adjust Frame to Image, 

➤ With a click-drag operation on the small red 
square in the right lower corner of the frame, you 
can now resize the frame so that it fills the 
column created by the guides.



WORK ON YOUR PICTURE
➤ Maybe you would like to center your image or to drag 

the picture inside the frame to the left or to the right 
or to make it bigger to focus on a detail.  

➤ To move the picture(inside the frame), make sure the 
picture frame is selected, go back to the Properties 
dialog box, and click on t 'Image'. In the field marked 
X-Pos (Pos=positions), just type in a value or click 
on the arrows to move the image horizontally (Y-Pos: 
will move it vertically). 

➤ To enlarge the picture, work with the size fields 
(Width and Height). The little chain to le right if 
closed maintains the picture proportion 

➤ Extra parts of the picture will get automatically 
cropped out of view beyond the boundaries of the 
picture frame.
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    This 
picture  
must 
shift  
to the 
left to be 
centered

➤ The frame determines what the size of the image will be, 
not its own size! 

➤ If the image is not displayed: select the frame, click with the 
right mouse button, preview>visible image. 

➤ When the images are high definition or are heavy or  too 
numerous, the software may slow down: Right button> 
Preview Settings> Low Resolution or color the frame. 

➤ In the same menu there is Image Effects. This allows you to 
apply some filters to your photo without having to use a 
photo editing program.



8 - COLORS, WHY NOT?
➤ There are a number of color palettes in Scribus, 

(Properties>Colors )but in addition you may edit, remix, or 
add colors to create your own sets.  

➤ Go to Edit>Colors. A dialog box listing existing colors 
displays on your screen. Click on 'New' and give your new 
color a name. In the second dialog-box that opens up, choose 
CMYK as the Color Model. This closely follows the inks of 
Cyan, Magenta, Yellow, and Black, used in your desktop printer 
and in printing plants, that mix inks to create new colors. With 
the sliders at the bottom, give the percentages you want  

➤ If your idea is to publish only an e-catalog in PDF you can 
choose RGB as color model (it is the right model when a layout 
is read on a screen)  

➤ Properties>Colors allows you to decide the opacity of your 
color so you can transform black in gray red in rose and so on 
using different percentages of the chosen color

CMYK and RGB (red, 
green and blu) models
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9 - LET’S GO FOR A DIGITAL EDITION
The special PDF tools in Windows > PDF Tools put some interactivity in your PDF. 

BOOKMARKS 
To navigate through a large PDF bookmarks can be made in your Scribus document 
Window>Bookmarks

Right-click on the text box you would like to set as a bookmark 
PDF Option>PDF Bookmark  
Repeat this action on every text box in your document that you would like to 
bookmark. Now check your Bookmarks palette. You will see a list  
of Bookmarks you have made. Using your mouse, just drag and drop your 
bookmarks to rearrange them.  

LINK 
In some digital books, you may want to add links between pages that occur in your 
document, such as links from the entries in your Table of Contents to your chapter 
first page, or links from text and notes or to destinations outside your document, 
such as a web site. 

Click the Insert Link Annotation button. It looks like two manly footprints.  

Now draw a box around your source area, then right-click on it to expand a menu. 
PDF Options >Annotation Properties>Link. Then set your INTERNAL 
Destination details 
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To set an external destination, such as a web link:  
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Right-click to expand the menu - PDF Options>Annotation Properties. 
Now, choose External Web-Link from the Type menu.  
In the Destination field, type or paste the web URL
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10 - EXPORT AS A PDF
Exporting is easy! 

Print>Save as PDF.  

automatic 
check: control 
or ignore your 

mistakes
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All the settings 
you can choose

The settings 
which apply to 
situations when 
a PDF is digitally 
transmitted and 
viewed 
electronically 
are included in 
the Viewer and 
Color tabs.       
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